0
Portfolio Summary gains do not match what is indicated in performance
Topic Starter
Wed Jun 19, 2019 - 20:49
Something does not add up. Rharian Portfolio summary correctly indicates a profit of 0.2% but when it gets transferred to the performance it shows a -1.49% a similar problem yesterday but smaller magnitude
9 RESPONSES
0
Thu Jun 20, 2019 - 08:02
I have to agree, it doesn't add up. The portfolio's equity changed from $382,621 (18 June) to $376,926 (19 June) which is -1.49%, but the net profit of positions for that day was positive. We'll look into it right away.
0
Thu Jun 20, 2019 - 08:49
It looks like we have a bug in a new backend process (implemented 28 May 2019) for recovering cash when exiting a short position. We'll get this fixed right away and make the appropriate corrections to the strategy's equity/cash curves and performance. Thanks for the heads up!
0
Fri Jun 21, 2019 - 03:45
My email said the gain for today was 0.00 but it was actually $800. I didn't have any short positions.
0
Fri Jun 21, 2019 - 05:50
We fixed the bug for exiting short positions, but we're still working on correcting the cash/equity curve data since 28 May. I'll let you know here when it's complete.
0
Fri Jun 21, 2019 - 09:37
Okay, history and performance should be correct now. Let me know if you detect any problems. Thanks!
0
Fri Jun 21, 2019 - 17:59
Although everything looks correct now for covered shorts, it looks to me like there may still be a problem with the "current equity" calculation with short positions. Stand by!
0
Sun Jun 23, 2019 - 17:11
We've correctly recovered the equity/cash and recalculated performance. Everything is correct in the model portfolio again. (I'll correct the subscriber's portfolio later.)

The only thing to note is that the Friday's (21-June-2019) portfolio change is showing -$783.03, when in reality it was -$1,106.21. For some reason the system calculated that total as if the positions in SPY had only changed -$0.43 when in reality it had changed -$1.86 from Thursday. Not sure how that happened, but we'll have to keep an eye on that!
0
Thu Jun 27, 2019 - 10:19
We've got the WealthSignals out-of-sample test back on track for the model and subscriber(s). Sorry for the hiccup!
0
Thu Jun 27, 2019 - 13:50
Thanks for fixing that
To reply to this topic, you need to login first.