1
New publisher here, how do I upload my backtested results like others have?
Solved
Topic Starter
Mon Feb 11, 2019 - 22:18
Hello, I'm trying to figure out how to deliver my back-tested research results to this system? I see others have done it successfully so I know it's possible, but for some reason I don't see how.

Any help regarding how to accomplish this would be appreciated... my Strategy is titled "Trend Follower"
18 RESPONSES
0
Tue Feb 12, 2019 - 06:08
Hi,

Currently you can do it if you have access to Wealth-Lab Pro with an extension tool called WealthSignals Publisher version 2019.01 or greater. Please visit the direct link to install it, restart WLP, and follow suggestions in the article to set things up.

Should you have questions or issues just let us know - we're here to help.
0
Topic Starter
Wed Feb 13, 2019 - 18:13
Hello again. Yes, I think I might need further assistance. I tried downloading the link you provided but it's a WLE file which apparently my computer doesn't have any way of opening/using? I tried following the path described in the article provided but I couldn't find the link where I connect my Wealth Lab Pro software model with the Wealth Signals account? Any other ideas that could get me back on the path? Thanks for the help.
0
Wed Feb 13, 2019 - 19:14
On how to install or update Wealth-Lab extensions, check out this illustrated tutorial (or the Wealth-Lab User Guide > Extension Manager).

I'm pretty sure that the WSP online guide contains detailed instructions on connecting a Strategy with your WS account. If you have a specific problem, please explain it clearly, and possibly attach a screenshot to illustrate what you're seeing.
0
Topic Starter
Wed Feb 13, 2019 - 21:36
I've got the model linked up now, thanks.

Last question, do I need to submit the current holdings as "Today's Signals" so that they get purchased or is it assumed that by tomorrow it will have those current positions in the system for new subscribers to see?
0
Thu Feb 14, 2019 - 05:48
Good news, seeing your system's results!

On the initial backtest results upload, any open position your system might have been holding is reported as closed at the Close price of the last bar. It's not transfered as an open position. To avoid a synchronization issue I'd recommend to not "reenter" them and just wait for new out-of-sample signals from your system. Any new exit Alerts may be auto-discarded by WS itself when you transmit them from WLP or you could use Publisher's Synchronize feature which would wipe them away before they're transmitted.
0
Topic Starter
Fri Feb 15, 2019 - 00:02
Sorry to bother you one more time. So I think I get it now. I decided to re-configure my strategy and now there are 3 of them with the only difference being the size of the purchase percentages. Can you review these to make sure I created them right? I called them Trend Follower 14, 25, and 100 indicating the max number of holdings. I didn't see the annual performance backtest data appear for calendar year the way it did before... can you make sure this info got uploaded right?
0
Fri Feb 15, 2019 - 05:36
No it's not right. The performance block of your backtest data has not been uploaded now. As per the online guide, usually this happened when system author's machine had an issue with the corrupt historical price data. It's impossible to upload the missing block so the only way is to create a new system, choose the data range that worked for you before, and re-upload.
0
Topic Starter
Fri Feb 15, 2019 - 07:19
I tried creating two new ones to replace the corrupted data strategies and I'm even using a different computer but I'm not sure the issue is resolved. Can you look at the new ones titled "trend follower focused" and "trend follower diversified"? I uploaded backtest data but it doesn't seem to be showing calendar year and monthly data? Any ideas what else I can try to fix this? Thanks again.
0
Fri Feb 15, 2019 - 07:31
I have no idea what fails on your end as I was never able to reproduce it. It's not the corrupt strategy, it's about the data or data range. So my suggestion was to use the same data range that worked for your first (deleted) system - or you could choose a different date range in WLP and create new systems until upload of results finally works for you. If you wish the WealthSignals admin could probably restore your first (deleted) system? No other suggestions.
0
Topic Starter
Fri Feb 15, 2019 - 16:31
Yes. If the admin could restore my first system that one works for me. Let me know how to go about that. Thanks.
0
Topic Starter
Fri Feb 15, 2019 - 18:01
If you need it, I believe the original strategy that we are going to resurrect was called simply "TREND FOLLOWER" if that's helpful in finding it and bringing it back to life. Thanks!
0
Sat Feb 16, 2019 - 10:43
The "TREND FOLLOWER" strategy has been restored but its uploaded backtest results have been purged, unfortunately. Sorry but my resource to troubleshoot and fix this rare issue has been very limited.

At least you have (one) chance to reupload. You might want to apply the exactly same data range when upload succeeded at first.
0
Wed Apr 17, 2019 - 09:50
As a followup, in the recently released v2019.04 of the WSP we tried to warn the author on incorrect equity curve:

QUOTE:
Change: warning when uploaded backtest results contain empty equity curve and/or zero trades

https://www.wealth-lab.com/Extensions/Details/50
1
Fri Apr 19, 2019 - 16:56
We have a handle on the problem with upload of backtest results which affects a few system authors. Basically, the equity curve fails to upload if it balloons too high. While leaving the truthfulness of it up to the authors, our team is working on a fix. Here's another update of the WSP which should help re-upload results after tuning the system's backtested equity curve in WLP/D.

What's new in version 2019.05 of the WealthSignals Publisher?

* Change: improved error handling during upload of backtest results. WSP will now detalize the error, delete the uploaded results and let author fix his system and re-upload results from scratch
0
FVB
Tue Jan 14, 2020 - 15:36
Is it possible to load historical/backtest returns with Qstudio?
0
Tue Jan 14, 2020 - 15:43
No. At the moment, only the WealthSignals Publisher supports uploading the historical results.
0
Sat Jan 18, 2020 - 14:31
Actually I do have a QStudio extension that is capable to uploading backtest results. You can contact me privately if you want to give that a shot (info@quantacula.com). The only caveat - it's designed to work for new strategies and I'm not sure yet of the impact of uploading backtest results for a strategy that already has published history on WealthSignals. If you ever wish to start fresh with a new strategy this extension could be an option.
0
Sat Jan 18, 2020 - 14:45
QUOTE:
I'm not sure yet of the impact of uploading backtest results for a strategy that already has published history on WealthSignals

AFAIK, this is not allowed. Backtest results should be allowed prior to making first live trade.
To reply to this topic, you need to login first.